Mikrotik Router PPPOE Server Setup with CISCO VLAN

Basic Ip 
Point to Point Protocol over Ethernet is a network protocol for encapsulating ppp frames inside ethernet frames.It is old DSL connection.PPPOE provide layer 2 encapsulation and user name and password for authentication for user.When we have many user in a same broadcast domain then our network maintenance tshoot have big problem. In this situation if our network topology breakdown in the layer 2 VLAN then many problem have been solved and network efficiency is grow.

Address Configuration :
/ip address
add address=103.254.248.206/29 network=103.254.248.200 broadcast=103.254.248.207 interface=WAN
         
Ip Pool configuration for PPPOE user :
/ip pool
add name=PPPOE ranges=172.18.10.1-172.18.10.254
/ppp profile
add name="PPPOE" local-address=172.18.10.1 remote-address=PPPOE dns-server=8.8.8.8,4.2.2.1
interface vlan
add name=1000-Admin  interface=Local  vlan-id=100
add name=200-Noc  interface=Local  vlan-id=200

/interface pppoe-server server
Add service-name="PPPOE_ADMIN" interface=ADMIN max-mtu=1480 max-mru=1480
     mrru=disabled authentication=pap,chap keepalive-timeout=10
     one-session-per-host=yes max-sessions=0 default-profile=default

 add service-name="PPPOE_NOC" interface=NOC max-mtu=1480 max-mru=1480
     mrru=disabled authentication=pap,chap keepalive-timeout=10
     one-session-per-host=yes max-sessions=0 default-profile=default


Create a PPPOE  User:
/ppp secret
 add name=asd service=pppoe password=123 profile=PPPOE local-address=172.18.10.1 remote-address=172.18.10.3

Bandwidth Control Using PCQ Method:
/Queue type
add name=PPPOE_1M_DOWNLOAD kind=pcq pcq-rate=1M pcq-classifier=src-address
add name=PPPOE_1M_UPLOAD kind=pcq pcq-rate=1M pcq-classifier=dst-address
/queue simple

add name="Total" target-addresses=172.18.10.0/24 interface=all parent=none
      packet-marks="" direction=both priority=8
      queue=default-small/default-small limit-at=0/0 max-limit=0/0
      burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s
      total-queue=default-small
                       
add  name="PPPOE-1M User" target-addresses=172.18.10.0/24 interface=LOCAL
      parent=Total packet-marks="" direction=both priority=2
      queue=PPPOE_1M_UPLAOAD/PPPOE_1M_DOWNLOAD limit-at=0/0 max-limit=0/0
      burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s
      total-queue=default-small
Lowest priority is better than other, If use this type of queue then we can easy to manage bandwidth  a group of client

NAT Configuration:
/ip firewall nat
add action=masquerade chain=srcnat



IP Route Configuration: 
/ip route
add dst-address=0.0.0.0/0 gateway=103.254.248.201



Cisco Switch Configuration:
Switch>enable
Switch#configuration terminal
Switch(config)#interface fastethernet 0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan all
Switch(config-if)#switchport nonegotiate
Switch(config)#vlan 100
Switch(config-vlan)#name ADMIN
Switch(config)#vlan 200
Switch(config-vlan)#name NOC
Switch(config)#interface fastethernet 0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 100

Switch(config)#interface fastethernet 0/3
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 200


Switch#wr

Comments